Web Attacks (Angler Exploit Kit Website 6) on my PC every time I log on to Sways

Hi Mod’s,

               an fyi for you; most every time I access the Sways forum my anti-virus software reports it has blocked a “Web Attack: Angler Expoit Kit Website 6”.

The “Attacking Computer” listed for each of these attempted intrusions changes every time it occurs.

Is it just me or are other people having this happen too?

Cheers all.

I just get the error page a lot lately http://www.swaylocks.com/forums/broken-links

I get a notice that a website has been blocked, because of securty errors.       Every time  I log into Sway’s, as well as many times during my session.

I get the error page a lot and the thing is s…l…o…w.  Mike

I just got (IT) when I tried to respond!      Can it be fixed, now that we know?

A pm has been sent to site owner.

Yep, that sounds like it - and, like you, I also get the error message popping up at seemingly random occasions during a session in addition to the initial logon.

I’ll be quietly reading away on a thread when (without me clicking on anything or doing anything) the message will suddenly pop up out of nowhere - and it got me thinking; it may not be the sways site/server itself that’s the problem as the only thing that changes while viewing a thread without any input from the user is the advertisements that appear and change in the “frames” around the outskirts of the webpage -> perhaps it’s the website/servers that are supplying the web content of those advertisements that are infected with this “Angler Exploit Kit Website 6” thing and are attempting to attack your pc via the advertising frames on the Sways webpage?

That would explain why the “Attacking computer” is different every time there is an attempted intrusion when viewing Sways webpages(?)

As for the “broken-links”/Error page and general slowness, I’m getting that too, but I don’t get the “Web Attack” message in conjunction with it - they seem to be seperate issues (am guessing the broken-links/Error issue is caused by the server responding/running slowly for some reason and on some occasions it responds so slowly that a timeout gets triggered and you’re taken to the Error page).

Just a guess though as to the possible causes of these issues - hope it helps.

Cheers all.




I posted about the error messages in the “Errors and Bugs” section a few days ago.

As to L.I.T. 's problem, if you are getting strange messages about an exploit and it seems connected to ads, then you should be using adblock plus in your browser.

I haven’t seen a single ad on Swaylocks in about six years. Adblock plus is your friend :wink:

A little online research says that this exploit is very common and infects machines running IE or Flashplayer, for the most part. Sways does not use Flash for any of its content, from what I can see. The ads may use it, but I have those blocked completely.

If you’re using IE I suggest you switch to a better browser.

If you ever check the site on an iPhone/iPad the sight will randomly take you out of safari and into the App Store. It’s not a pop up, it’s a whole different program. I though it might have been iPad but I’ve tested several others and the same thing happens. 

I have an I phone and I don’t get that, but my complaints are that pictures only show half the time, and its way too easy to just brush the screen and inadvertently give an up or down vote.  I can type a post, and the screen freezes about midway through a post.  Then I have to switch to plain text to finish.  I also can’t scroll the text as I’m typing, unless I’m in plain text mode, and then its really tedious and awkward.  The tool bar at the top of the posting screen is only half there (the left half).  Oh, and the edit button is superimposed with the vote buttons, so sometimes I want to go back and add a second thought, I tap the edit icon, and I keep getting this “you can’t vote on your own post” message.  And yeah, that irritating “error” message half the time, and when I just hit “save” everything I typed is gone.  Its kind of an exercise in frustration, but sometimes that’s the only access I have, working out of town a lot.  

My iPad was auto launching in to apps, now it’s going to uber.com every time I enter site. 

Now just automatically going into all different sites. Trying do a search to research some different rockers is proving itself impossible 

Huck, I have all those same issues as well. I am the farthest thing from an apple fan. The iPad is a must have for work, I chalked all that up to Apple’s unwillingness to work well with others, ie - flash.

Well, yesterday the “Web Attack” issue got even worse for me; tried to access the Sways website (I use the “General Discussion” page as my “landing page”: http://www.swaylocks.com/forum/general-discussion), the 'page started to load (hadn’t even logged on to my account yet) and this time my anti-virus software stopped the page from loading and instead displayed it’s own webpage stating that the site I’d just been trying to access had attempted to attack my PC using the “Angler Exploit Kit 8” and the risk was too severe to allow me to access that site.

In short it had blocked me from accessing the entire Sways website.

Too risky it said.

In the past it’s always been a little message box popping up on one side of the toolbar letting me know an attempted intrusion from “Angler Exploit Kit Website 6” had been blocked. It’d pop every now and then and disappear.

This time though it was the “8” version of the Angler Exploit Kit rather than the “6” one, and my anti-virus software just wouldn’t have a bar of it.

So I figured, others (in particular the Mods and Admins) ought to be experiencing the same issues and would be addressing the problem - a website that can’t be accessed at all is of no use to anyone, so I figured give it 24 hours for the issue to be addressed and try again.

It’s been 24 hours now, my anti-virus software had no issue with me accessing Sways and there haven’t even been any “Web Attack” messages at all so far today.

I presume the issue’s been resolved now and Sways is safe again?

Incidentally if anyone’s interested in the “Angler Exploit Kit” check this out (https://blogs.sophos.com/2015/07/21/a-closer-look-at-the-angler-exploit-kit/) for an explanation of what it is, how it works, how to detect it and remove it from your website, and how widespread it’s become in the last 12 months - looks like it’s quite a prolific little thing.

I installed the free adblock that SammyA mentioned and… Bingo! No more ads!!  Thanks Sammy.

I can not get anywhere on Swaylocks…I get “error 404” and bounced around everywhere. Too much trouble to deal with. Sorry about unanswered PM’s etc. Hope something changes soon…

installing ad blocking software is like taking money out of sways’ pocket for the already-free resource, ya know. it may only be pennies here and there, but every bit helps keep this site alive, i’d imagine.

(and no, i have nothing to do with running sways, but i do respect the effort they put into things here so i don’t care about seeing google ads…which are not the real reason you’re having problems)

The only way I can access the site is to run an ad blocker.  If I don’t, I’m redirected to other sites.